r/firstworldproblems • u/cr7808 • 5d ago
My wife is convinced email addresses are case sensitive. She refuses to believe otherwise.
Yes, she means email addresses, not passwords
54
u/anaccountofrain 5d ago
The part before the @ is handled by the local server and can be handled any way that server chooses. Most servers are case-insensitive, but it's not required. More here. In short, if you're building a server, case-insensitive is more common, but if you're passing along email addresses maintain their given case in case it matters to the originating server.
With gmail, it ignores case; it also ignores periods so that firstlast and first.last are treated the same. It also ignores a '+' and anything after it, so you can sign up to a service with first.last+service@gmail.com and it'll still end up in your inbox.
The part after the @ is a domain name and is required to be case-insensitive.
11
u/MysteriousPickle 5d ago
I do this so that I can figure out which companies sold my information and probably shame them. I wish my password manager would do this automatically when I sign up for things.
Maybe there's a browser extension I could find.
9
u/The-Yar 4d ago
Gmail actually has a lot of built-in features that allow you to do this. Like if you are dufus@gmail[.]com, you can register on a web site as dufus+website@gmail[.]com and it will still come to you.
3
u/ice456cream 4d ago
Someone didn't read the first comment in this thread
Plus addressing was already explicitly mentioned as a Gmail feature
2
u/grandma_corrector 3d ago
It’s hard to imagine companies that are selling info this way to not just scrub the + part from gmail addresses but 🤷🏻♀️
2
7
u/DanSWE 4d ago
>so you can sign up to a service with [first.last+service@gmail.com](mailto:first.last+service@gmail.com) and it'll still end up in your inbox.
Except for the services that reject plus characters ("+") as illegal e-mail address characters (and reject addresses containing then) because too many programmers of e-mail address validation code are too lazy or incompetent to look at the relevant standard (IETF RFC 5322), which specifies that plus characters (and quite a few other non-alphanumeric character) are indeed valid in the local part.
:-(
I used to try to use plus-addressing like that, but I ran into too many sites that wouldn't accept it, so I ended up getting a domain service where I can create aliases that look like "regular" e-mail address but which all forward to my real e-mail account.
1
u/ice456cream 4d ago
Imo a domain is the smart way to do it anyway (for all main delivery) since you are not locked to any specific provider.
E.g. my parents still heavily use an isp provided email (and has been for a long time), which is reducing their options until stuff is migrated off
1
u/Kushali 2d ago
I used plus addressing until I needed customer service and they wouldn’t engage with me until I emailed them from the registered email. Gmail does not let you SEND from a plus address so I was SOL.
1
u/DanSWE 2d ago
> Gmail does not let you SEND from a plus address
Which is stupid, because Google/Gmail knows that a plus address will deliver to your base e-mail account, so they should let you sent from (i.e., set the
Fromheader field) from one.I think Gmail has some way of registering other addresses for use as the
Fromaddress, though the (one) time I tried it, either something didn't work as expected, or there was some limitation.Gmail does let you send with
Reply-Toset to some other address (at least when using an IMAP client; I don't know about when using the regular Gmail web interface. (At least the last time I tried usingReply-to, several months ago.)11
u/thedufer 4d ago
So disappointing how far down the correct answer is. Most people in these comments think Gmail is all of email.
3
1
u/bbqroast 2d ago
If you run a mail server that enforces case though you've lost your mind.
1
u/thedufer 1d ago
It's not a good idea on incoming mail, but it's a terrible idea to treat mail on domains you don't own as case-insensitive, because you will occasionally be wrong and deliver mail to the wrong account.
MS Exchange permits this, and supposedly some domains have made use of it.
But yeah, don't choose this for yourself.
2
1
1
u/pv2b 4d ago
Technically, the email server at example.com could deliver mail for joe@example.com and joe@EXAMPLE.COM to different mailboxes. Even though dns itself is case insensitive
1
1
u/nightowl_work 1d ago
Boy do I have a fun game (not affiliated with me, I just know of it) for you:
0
u/Truji11o 5d ago
Pretty sure OP’s wife isn’t going to be receptive to that information.
14
7
1
u/hombre74 5d ago
She could try it out herself though.
5
5
u/laplongejr 4d ago
Why would she try anything? They CAN be case-sensitive, it depends on whoever runs the email.
1
u/ice456cream 4d ago
And even if it is case insensitive delivery, the too field will be case preserving based on the case of whoever sent it
38
u/Slippery__Slope__ 5d ago
Seems like an extremely easy thing to prove
4
u/cr7808 5d ago
You would think so. But the next time it comes up, she asks again about upper vs lower case.
20
u/Truji11o 5d ago
Sit down with her. Send an email to yourself, or have her send an email to you - once with the correct case, and once with tHE WrONg cASe. Why is this so hard?
10
u/Slippery__Slope__ 5d ago
What does she say when she receives an email to HeReMaILaddRess@gmail.com
7
u/Truji11o 5d ago
Or, just to really drive it home, if her email is janedoe@domain.com, go to domain.com and try to create a new email account with jAneDoE@domain.com
1
u/ice456cream 4d ago
Oh look, Gmail kept the case the sender used. That means both my local email server, and the senders email server, chose to preserve the case as-is.
The case has meaning. If not to the email server itself, then maybe to the users filters? Maybe to the user itself?
3
u/HerrHendrik 5d ago
It is defined as case sensitive (the first part before the @), but providers don't follow this, as it can lead to mistakes. So technically they are if an email server chooses to adhere to the RFC 5321 (documents with rules about how internet should work). But practically, no.
15
u/CantaloupeCamper 5d ago
Wait until you tell her about the + sign…
8
u/Fireislander 5d ago
Or a . in a Gmail address (and probably others)
3
1
u/Imperial2187 5d ago
Used to work at a place where my worth as an employee was measured in rewards program sign-ups. The system was smart enough to know if an email was already signed up, but not smart enough to populate the account number when it gave me the “user already exists” message. Was also smart enough to know if the email was real or if i mashed the keys and put a gmail domain at the end. I knew about the gmail (.) thing, and I abused it. But yeah, most emails are like this, with the exception of yahoo, which always told me it was invalid after trying to add the (.)
9
u/meramec785 5d ago edited 5d ago
Blow her mind and add random periods. C.r.78.08 maybe a + c.r7808+isright@
3
u/ul2006kevinb 5d ago
Lol I came here to say that my wife is 100% convinced that the period in her email address is necessary and won't be persuaded otherwise.
4
u/MeIsMyName 5d ago
Depends on the email provider. Gmail is the only one I know for sure that ignores dots.
1
u/ul2006kevinb 5d ago
Really? Well I'll take my foot out my mouth then. It's a Gmail account but i told her they all ignored it.
2
u/laplongejr 4d ago
Well, ignoring dots is like case-insentivity : it's a convention from the provider, but the standard doesn't force them to do so. All combinations could be someone else.
1
u/Winter-Volume-9601 3d ago
You also never know (unless you know how to check) - an arbitrary company's domain can be hosted via https://workspace.google.com/lp/gmail
9
u/froction 5d ago
A recipient server COULD make addresses case sensitive, but there is a roughly 100% chance that the ones you're dealing with don't. I have been in this business 30 years and never seen one that was.
2
u/ice456cream 4d ago
However, from a service/sending perspective you must retain/preserve the case the user entered, since you don't know if the case has any special meaning
It's up to you (but you probably should) ignore case when using it as a user identifier / disallow duplicates differing only by case
6
u/w1n5t0nM1k3y 5d ago
Technically the part before the @ sign could be case sensitive but none of the major providers implement it that way
3
u/odeebee 5d ago
I remember the early email days before everyone figured out this convention. It was a CluSterFux for sure.
1
u/AvonMustang 2d ago
I’m positive my first couple of email addresses were case-sensitive - first used email in the 80s.
15
u/definitelynotjava 5d ago
This isn't a first world problem. This is either a "I cannot show a simple proof" problem or "my wife doesn't understand simple things" problem
-7
u/Hello_I_Am_Human_Guy 5d ago
You basically just described first world problems lmao
0
u/definitelynotjava 5d ago
No. First world problems are this kind of problem can only happen to someone who already has luxuries. Having an email is not a luxury.
-1
u/Hello_I_Am_Human_Guy 5d ago
"a minor difficulty, annoyance, or frustration experienced by people in affluent or developed nations that seems trivial when compared to severe issues like poverty, war, or disease in poorer regions." You're down voting me because you don't even know what the term actually means. Your wife refusing to believe that email addresses are not case sensitive is not an issue that someone suffering from maleria or who lives in a war torn nation would care about. You cannot be this arrogantly ignorant lol.
2
u/definitelynotjava 5d ago
It is not limited to affluent regions. People all over the world, even in poorer countries and territories have emails and, in some cases, fail to understand it. You not being congizant of global reality is not my fault. It's 2026. The Internet is everywhere
9
u/catroaring 4d ago edited 4d ago
Your wife is technically right. Per the IETF standard anything before @ is case sensitive, it's just that most modern email services treat it as case insensitive.
SOURCE: IT professional and recently just had an issue with this for a user on their personal account.
sensitive @ insensitive.insensitive / sensitive
3
2
u/J_Peanut 4d ago
That’s not correct. Per the standard the local part is completely up to the host.
It was a problem that other entities than the host tried to interpret an address and make delivery more efficient. But that’s not what the standard specifies.
When using email addresses in other systems (e.g. for authenticating a user), it is bad practice to not treat email addresses as case insensitive. Any communication will have to go to the email address you assume to be the correct one, but anything else is anyways negligent.
This is what the relevant RFC gives us on the local part:
The local-part portion is a domain-dependent string. In addresses, it is simply interpreted on the particular host as a name of a particular mailbox.
1
u/catroaring 3d ago
You're confusing a host's discretion with the protocol's transmission requirement.
Per RFC 5321 Section 2.4 (General Syntax Principles and Transaction Model):
"The local part of a mailbox MUST BE treated as case sensitive. Therefore, SMTP implementations MUST take care to preserve the case of mailbox local-parts. In particular, for some hosts, the user "smith" is different from the user "Smith"."
4
4
u/ThatGuyOverThere2013 5d ago
Technically, it's possible to support case-sensitive email addresses, most entities never bother with it, because it makes no damn sense. Ignoring case is the safer route.
10
u/3string 5d ago
I think they might have been like that at some point. With Gmail in particular though, Google put through a big update about ten years back that simplified a lot of email addresses, or made similar-but-mistyped addresses all go to the same recipient.
There might be other email services that technically allow for upper case names being different. The vast majority of them work like Google does though, and email addresses are generally always written in lower case.
9
6
u/fakemoose 5d ago
RFC 5321 dictates they are case sensitive.
In reality, they usually are not.
6
u/wosmo 5d ago
It doesn't dictate that they are. It dictates they should be treated as case-sensitive, incase the receiving system behaves that way.
It's a subtle difference, but if they are case-sensitive, your receiving system should behave that way - which isn't what it's asking for.
(I usually call this case-preserving. You can act as though it's insensitive, but preserve the case incase the next system doesn't.)
1
u/ice456cream 4d ago
From every perspective apart from the recieving mail server itself, it's the same thing, it's up to the mail server to decide what to do.
It also says it's locally defined behaviour.
Additionally even if it appears to be case insensitive, it still (will likely) preserve case during delivery, even if 2 emails differing only in case go to the same inbox
2
u/edman007-work 4d ago
They were, from RFC 821
Commands and replies are not case sensitive. That is, a command or reply word may be upper case, lower case, or any mixture of upper and lower case. Note that this is not true of mailbox user names. For some hosts the user name is case sensitive, and SMTP implementations must take case to preserve the case of user names as they appear in mailbox arguments. Host names are not case sensitive.
However, RFC 5321 says while they are still case sensitive, mail servers shouldn't do that:
In particular, for some hosts, the user "smith" is different from the user "Smith". However, exploiting the case sensitivity of mailbox local-parts impedes interoperability and is discouraged.
4
u/FlippingPossum 5d ago
I definitely recall them being case-sensitive many years ago. Like, my college email in the '90s.
3
u/vbf-cc 4d ago
In the early days, your email address was just your Unix username @ the host name: johnny@kelvin.physics.fabercollege.edu. Usernames were definitely case sensitive and almost always issued in lower case. JOHNNY and Johnny would each have been different users, though it would have been rare and confusing to do that.
Host names were also case sensitive in Unix, but again, conventionally lower case.
As systems began to support full name aliases, like John.Smith, I believe it became common to support case insensitivity.
Ignoring the period is unique to Gmail, and not that anyone asked me, but I honestly don't see the reason.
Plus-addressing is a documented standard, supported by many but not all mail systems. Microsoft allows it in Exchange and Microsoft 365 but if the organization has an anti-spam system as their front end, it may or may not be configured to allow it.
2
u/Cool-Firefighter2254 5d ago
Yes, my first email address from the very early 1990s (maybe late 1980s) was case sensitive.
1
u/Jasoco 5d ago
This explains why I still get emails meant for some Spanish speaking family. Receipts and newsletters all the time. I hate it so much. I already get enough junk I can’t fix. And a little tip for everyone, never register for a political party. No matter how many times you unsubscribe from their emails you’ll be getting donation begging every two years for months.
7
u/794309497 5d ago
If the email address is being used as the username for another website, it could be case sensitive. Maybe that's what she means.
3
3
u/According_Park3150 4d ago
Is this really a hill you want to die on?
1
u/Primary_Wonderful 4d ago
You beat me to it. My husband thinks the same thing. There is no benefit to anyone to make a big deal about it. It affects nothing. Now, the words 'beinhave' & 'icning' on the other hand will send me into fits of rage.
6
u/krendyB 4d ago
OP - your wife is right. It depends on the email server. Some are in fact case sensitive. Ours at work are (sigh, I wish they would change it).
1
u/tunaman808 4d ago
According to RFC 5321, domains are never case-sensitive, and although usernames CAN be case-sensitive, it "impedes interoperability and is discouraged."
https://www.w3tutorials.net/blog/are-email-addresses-case-sensitive
2
2
u/J_Peanut 4d ago
She is not wrong and neither are you. Email is a mess. The email address consists of a local part and the domain, separated by an @. While the domain is somewhat regulated, the local part is completely up to whoever serves your mailbox. And for good reason - the last time it was tried to standardise that, nobody stuck to the standard and it caused incorrect deliveries of emails.
For example gmail and outlook ignore dots, have plus-addressing, and don’t care about case sensitivity
But at the same time gmx, a popular email service in Germany, only ignores case sensitivity and treats email addresses with a dot in them as a different email address than the one without the dot.
And most mail servers used by companies (including exchange) allow you to enable case-sensitive treatment of the local part. Almost nobody does that, but that setting exists.
So as a conclusion:
abc@gmail.com and ab.c+test@gmail.com are treated as the same address.
abc@gmx.net, a.bc@gmx.net, and abc+test@gmx.net are all different mailboxes.
And while the chance is slim, if a company (with the domain company.com) uses their own mail server these two email addresses can lead to different mailboxes: Abc@company.com and abc@company.com
2
u/garrettj100 2d ago
Why is this a conversation?
Send two emails from your own account, to:
When she gets them both the problem is solved.
3
u/Imperial2187 5d ago
Had a guy tell me today “all lowercase” after he told me his email. I had to collect my thoughts after that one. Like I can see why you think that, but im not going to be the one to explain it to you
1
u/marinaasomething 5d ago
The amount of callers I had that would say something along these lines 🤦♀️ I thought it was older people, but then I got kids under 18 or even people of the age that should be computer literate saying the same thing..
1
u/laplongejr 4d ago
I'm computer literate. And I should tell "all lowercase" because I work in IT and know that the standards say addresses must be treated as case-sensitive
1
u/tunaman808 4d ago
Like I can see why you think that, but im not going to be the one to explain it to you
RFC 5321 says that email usernames CAN BE case-sensitive, but that "impedes interoperability and is discouraged". I had at least one client who set up his on-prem Exchange 2003 server like that back in the day. It was a setting in recipient policies, I think.
https://www.w3tutorials.net/blog/are-email-addresses-case-sensitive
1
u/Jasoco 5d ago
They’re definitely not. In fact Google is terrible at even getting mail to the right place. I still get emails meant for some Spanish speaking person with a completely different email address. And once I got email for an address that was spelled almost the same as mine with some periods in it. Either way I know they’re not case sensitive either because you can enter it all caps or capitalized when signing up for things and it’ll still work.
1
u/ice456cream 4d ago
Gmail ignores case, positioning/presence of periods, and plus addresses (everything after + at the end).
So those emails were all sent to you, by someone mistyping their own email
1
u/flanface87 5d ago
My superior at work also believes this - when I provided him with my email address a few weeks ago he asked if it was all lower case. I just paused and said yes. Our manager politely called him the department's 'weakest link' in a very awkward meeting that he was part of
1
u/hihowareyou_88 5d ago
I ask for email addresses every day as part of my job. Probably once a month someone will specify "all lowercase". Usually older people though.
1
u/No-Introduction3808 5d ago
I work with people like this, I do use capitals when sending someone an email address but that’s more so they can recognise the long string of letters encase there’s a mistake, sometimes they take it too literal.
1
u/SavannahInChicago 4d ago
The number of people who think this. I used to collect emails at work and our software was all caps only (very old software) so I didn’t argue with anyone. It’s going to be all caps if you like it or not.
1
u/WhiteRabbit86 4d ago
I just tell people lower case.
As the office tech guy I’ve long since accepted that my coworkers are tech illiterate and that trying to teach them anything is akin to asking a fish to fly.
1
u/orthros 4d ago
This is a common belief and I can't always get people to accept it
The more fun one is that you can put as many periods as you want in your email address because they're ignored
r.e.d.d.i.t@gmail.com and reddit@gmail.com are parsed the same
As well as putting anything after a plus sign, at least in gmail, so reddit+dumbemails@gmail.com will also go to the base reddit gmail address
1
u/ice456cream 4d ago
The period behaviour is more Gmail specific than the plus addressing (at least outlook consumers has also got plus addressing iirc)
1
1
u/GendoIkari_82 2d ago
Although Gmail does that; most sites that have you choose an email address for a new account do not. This means you can end up with people creating a second account on a system you already have an account for, which also is tied to your email.
2
u/utl94_nordviking 2d ago
The more fun one is that you can put as many periods as you want in your email address because they're ignored
Not true. email =/= Gmail
1
1
u/ryandury 4d ago
Just wait until she finds out you can add a period anywhere in the name and it still works..
[hello@gmail.com](mailto:hello@gmail.com)
[h.ello@gmail.com](mailto:h.ello@gmail.com)
[hell.o@gmail.com](mailto:hell.o@gmail.com)
They all point to the same address.
1
1
u/Leverkaas2516 4d ago
This is only a problem if you make it one. If she continues to believe that and operate on it, she will be fine. Nothing bad will happen. It's like believing that taking the charger out of the outlet when you're not using it will help the planet.
Are you the kind of person who just has to be right all the time?
1
u/ArtComprehensive1106 4d ago
Tell your wife to email you in all Caps. When it goes through you will have the answer!
0
u/ice456cream 4d ago
Yes and no.
No because that only shows your providers specific behaviour
Yes because you accidentally prove her point. It is very likely the provider will preserve case, so once the email is delivered to you, in the to: field you will see the exact case she entered, meaning the case was treated as meaningful, you just have the uppercase and lowercase (and all other case) variants
1
u/Deep-Hovercraft6716 4d ago
Have you considered looking at the Wikipedia article for email addresses?
1
u/BreakfastBeerz 4d ago
Blow her mind with what happens with a "." In front of the @
1
u/ice456cream 4d ago
That is Gmail specific behaviour
Unless you are talking about sending an email to "."@example.com, which is also perfectly valid
1
1
u/granolaraisin 3d ago
Belief doesn’t seem to have to factor into it? It’s a pretty easy thing to prove.
1
u/Careful_Bench 3d ago
Okay but…. Why do people think this… we take emails for people’s accounts at work and probably a good 1/4 of people specify lowercase or uppercase letters when spelling it out. WHY?
1
u/RScottyL 3d ago
yep, pretty much only passwords are case sensitive...
not usernames or email addresses
1
u/PossibilityOrganic 3d ago edited 3d ago
So your bothe right and wrong.
Your wife is right because the email spec allowed it apple@example and Apple@example can be diffrent mailboxes.
but most providers treat them as the same.
if you want to go down the rabbit hole.
https://youtu.be/mrGfahzt-4Q?t=957
this is the exact bit about the case sensitivity and why
https://youtu.be/mrGfahzt-4Q?t=1583
1
1
u/Beginning_Earth_9702 3d ago
Wife is technically correct. https://en.wikipedia.org/wiki/Email_address
1
1
u/damaltor1 2d ago
Thing is, she is not wrong. Not entirely wrong, at least. RFC5321 explicitly states that the personal part of the email address, the part in front of the @, is case sensitive.
Nobody cares though as it would be far to easy to get it wrong. All (?) email services treat it case insensitive.
1
u/lost_dazed_101 2d ago
Gmail is not case sensitive mine is all lower case but sites automatically put it in all caps and it goes through.
1
1
u/HiroProtagonist66 2d ago
Unless of course you create an account with the USPS Informed mail service.
Then you have to put it in IN ALL CAPS. /smh
1
1
1
u/DaCoolNamesWereTaken 1d ago
The portal for my energy company a few years ago was case sensitive. It was hell to figure out what was wrong with my login
1
u/JustPlainRude 5d ago
The part before the @ may be case sensitive. That's up to whoever is hosting the email service for a given domain. In practice, the vast majority of providers treat the entire address as case insensitive.
1
u/fakemoose 5d ago
A private server could still have case sensitive email addresses. Technically anything before the domain is case sensitive, but most email services no longer do that.
Services like gmail don’t even care if you use Fakemoose or fake.moose
0
u/dmada88 5d ago
Of all the many things in the world to be mistaken about, this would seem to be one to simply let go. Let her believe what she wants. Unlike medical misinformation , she’s not harming anyone, not even herself.
2
u/tunaman808 4d ago
She's not mistaken. Email addresses CAN be case-sensitive, but very, very few groups set up their servers this way, for obvious reasons.
0
u/Truji11o 5d ago
Until she says it during her kid’s STEM scholarship interview.
1
u/WinterAd6596 3d ago
But she'd be right. In theory, email addresses are case sensitive, even though most services don't treat them as such.
That said, why the hell would the parent be in that interview?
0
0
-2
u/cwsjr2323 5d ago
This is a not worth fussing issue. After you try to explain, just "Yes, I agree do as you choose ".
0
192
u/Truji11o 5d ago
Have you tried, idk, testing her theory with her?